Front hub install

Technical Area for all the problems you have in the garage
Post Reply
User avatar
Dave Woodward
T289R Member
T289R Member
Posts: 724
Joined: Sun May 06, 2007 10:00 pm
Location: Cheshire
Contact:

Front hub install

Post by Dave Woodward » Sat Mar 30, 2019 3:49 pm

I’m finally installing my rebuilt front hubs and have an issue with one of them. Pic attached.

It is a new stub axle assembly but the top and bottom mount points seem to be out of alignment. I’m assuming these should be parallel and this is a supply issue. Does anybody have a view.

Thanks.

Dave.
671FE2BD-F235-4597-9D77-225007C78475.jpeg
__________________________________
I say, ding dong!

User avatar
clive
T289R Member
T289R Member
Posts: 2937
Joined: Thu Mar 01, 2007 1:18 am
Location: Perth

Re: Front hub install

Post by clive » Sat Mar 30, 2019 5:53 pm

Doesn't look good to me Dave. How does it compare to the other side?
Cheers, Clive.

(If I'm not here I'm in my workshop or on the golf course!)

User avatar
Dave Woodward
T289R Member
T289R Member
Posts: 724
Joined: Sun May 06, 2007 10:00 pm
Location: Cheshire
Contact:

Re: Front hub install

Post by Dave Woodward » Sat Mar 30, 2019 8:32 pm

Hi Clive. Thanks for coming back on this.

I slackened off the top nut in the end and aligned the top and bottom. Has all gone together fine now. I just wasn’t sure as I’d assumed Moss Europe would have built it properly so assumed I was missing something.

Thanks again.

Dave.
__________________________________
I say, ding dong!

User avatar
StewbieC
T289R Committee
T289R Committee
Posts: 1117
Joined: Mon Oct 13, 2008 12:50 pm
Location: out in the sticks, Shropshire

Re: Front hub install

Post by StewbieC » Mon Apr 01, 2019 1:53 pm

Hi Dave,
Glad you've sorted things!
________________________________________________
Stu
Hawk 289, maximum smiles per mile..

Post Reply