Page 1 of 1

Electrical Issue

Posted: Fri Aug 23, 2019 9:07 pm
by stu60
Hi,
I know every build is unique but I am running out of ideas and wondered if anyone has come across this.

The Drivers side rear light, front side light (in headlight) and instrument lights have stopped working (the brake light is still working).

So far i have
- checked all the fuses under bonnet
- changed bulbs in rear light
- dismantled dashboard checked all wiring to switch (that was a pain!)

The passenger side lights and bootlid lights are all working and are routed through same switch so I am still thnking there is a fuse somewhere that i haven't found.

All ideas gratefully received!
Rgds
Stuart

Re: Electrical Issue

Posted: Fri Aug 23, 2019 10:43 pm
by peterc
I am sure that the lights are on two circuits so there will be two fuses.
I’ll check in the morning.
Peter C

Re: Electrical Issue

Posted: Fri Aug 23, 2019 11:23 pm
by clive
Definitely separate circuits for right and left sidelight circuits to prevent complete light failure if a fault occurs. I know, because I've been there! Both fuses are in the fuse box. Make a temp lead and try the earths.

Re: Electrical Issue

Posted: Sat Aug 24, 2019 8:10 am
by stu60
hi clive
thanks. I sat down with a cold beer and thought about everything i had eliminated and went back out at 10pm and wired accross the fuse terminals and hey presto it worked. Re-looked at the fuse i had looked at (at least 3 times) and there was a hairline crack but not at the thinnest part where you would expect.

bit surprised fuse is only 8A.

So lesson learnt, order new glasses!, apply logic and check 3 times before embarking on 3 hours strip down of dashboard!

thanks again
Stuart

Re: Electrical Issue

Posted: Sat Aug 24, 2019 9:21 am
by clive
Glad it is sorted. One thing I discovered when I built my car all those years ago was all the fuses in the supplied fuse box were 8 amp and some were not strong enough for the job. For example, the first time I used the horn in anger, a wee peep and the fuse blew! The canoe type fuses used to be ceramic but are now plastic and I have had the plastic melt! I eventually replaced the whole fusebox with a blade type which not only solved the problem but has given me better voltage throughout the car. https://www.halfords.com/workshop-tools ... way-hfs205

Image

Re: Electrical Issue

Posted: Mon Aug 26, 2019 10:41 am
by peterc
I was going to advise that the the off side lights are wired with the instruments and the nearside lights are wired up with the number plate.
Interesting I only have 7.5 A for the for the offsides lights and 3A for the nearside lights. Not had any problems over 20 years but just maybe I will now add up the wattage on every bulb as a check although the instrument bulbs have all been changed for LED’s so that will significantly reduce the load on that circuit. For reference all other fuses are 10A.
I have always had the blade type fuses with the Gerry supplied fuse box.
Peter C